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Note: Many of the accessibility issues of a PDF document can be found using the Accessibility Full Check. Adobe Acrobat Pro offers remediation tools, when applicable, by selecting Fix form the Options menu in the Navigation Pane.
To create an accessible PDF it is recommended to begin by opening the Action Wizard found in Tools and selecting Make Accessible. The Make Accessible tool will walk users through necessary steps to create an accessible PDF including a Full Check. Certain criteria cannot be checked using the Action Wizard and requires manual verification or modification. This document contains techniques to use Acrobat Pros standard tools to correct accessibility issues.
In many cases, it is recommended to use the authoring tool of the original document to remediate any accessibility issues and re-exporting the document to a PDF format.
[bookmark: _Toc504657971][bookmark: _Toc504658029][bookmark: _Toc504659748]How to achieve checklist item #1: Filename
File > Save or Save As…
Enter a filename using the following rules:
· No spaces
· No special characters (underscores _ and hyphens - are okay)
· No unfamiliar abbreviations
Accessible filename Examples:
· SmithB_Resume.pdf
· 04-12-16_Meeting_Agenda.pdf
· 20170101_Annual_Report_v1.pdf
[bookmark: _Toc504657972][bookmark: _Toc504658030][bookmark: _Toc504659749]How to achieve checklist item #2: File Properties
[bookmark: _Toc504657973][bookmark: _Toc504658031][bookmark: _Toc504659750]Set Title and Author
File > Properties...
Select the Description Tab.
Enter the Document Title and Author information in the appropriate fields (See Figure 1).
Select the Initial View Tab (See Figure 1), and then choose Document Title from the Show: drop-down list. This ensures that the Title is displayed whenever possible rather than the filename which may be less meaningful. Select OK.
Figure 1
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[bookmark: _Toc504657974][bookmark: _Toc504658032][bookmark: _Toc504659751]Set Document Language
File > Properties > Advanced 
Select a language from the drop-down menu within the Reading Options.
The Tags panel can also be used to apply language Properties to the text in a subtree of a tags tree. 
Language Properties can be applied to blocks of text using the Content panel.
Figure 2
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[bookmark: _Toc504657975][bookmark: _Toc504658033][bookmark: _Toc504659752]How to achieve checklist item #3: Interactive Elements
[bookmark: _Toc504657976][bookmark: _Toc504658034][bookmark: _Toc504659753]Links
Note: If the PDF was created using software that supports links then only the destinations need verification. Test any existing links to ensure correct functionality.
To create a link:
Select the text or element that you would like to become a link.
“Right-click” on the selected item and choose “Create Link”. 
Select Link Appearance options. Make choices that ensure that the appearance of interactive elements is distinct from that of surrounding paragraph text.
Select a Link Action e.g. Open a web page (See Figure 3).
Select Next. 
Follow prompts to set the link target/destination.
For links that Open a web page, enter or paste the URL for the link. 
Figure 3
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Note: Link text should be unique and should describe the topic or purpose of the link. Do not use link text such as “click here” and “read more”.
If the link purpose or destination is only recognizable within visual context, once links are assigned, the link text that is read to screen readers can be modified.
To add additional text description to a link; “right click” on the object in the Tags Navigation pane and select Properties... Select the Tag tab and enter the link description within the Actual text: text field.
[bookmark: _Toc504657977][bookmark: _Toc504658035][bookmark: _Toc504659754]Bookmarks
Bookmarks support the logical structure of a document and can facilitate navigation. It is best practice to apply structured Bookmarks to any document that has 21 or more pages. A document will fail an accessibility check within Adobe Acrobat Pro if this specification is not met.
Similar to Links, Bookmarks can be created using standard document creation software and are typically retained when PDF conversion is successful. Bookmarks can include; links to document objects, References and Table Of Contents.
Figure 4
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Bookmarks are functional in all modern PDF reading applications.
Create a bookmark by:
A. Selecting the text or object and “right clicking”.
B. Choose Add Bookmark (See Figure 4), and type a name for the Bookmark. The selected text or object becomes the destination.
OR 
C. Choose Create Link and select Go to a page view from the Link Action options. Follow the prompts to define the destination and select Set Link.
OR
D. Within the Bookmarks Navigation pane, select the options button and choose Add Bookmark (See step B), or select New Bookmarks from Structure… and select a Structure Element to create Bookmark(s) from (e.g.; Paragraph, Heading or Figure). Selecting OK will generate bookmarks for all applicable elements; for example, all instances of H2 headings.
Note: structure must be applied prior to this action.
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Use the Bookmarks navigation pane to view and verify all bookmarks (See Figure 5). Select the Bookmark to test the link.
[bookmark: _Toc504657978][bookmark: _Toc504658036][bookmark: _Toc504659755]Figure 5
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How to achieve checklist item #4: Tags
PDF Tags support the Reading Order and are necessary to create an accessible PDF.
Tags allow users of Assistive Technology to recognize types of document elements such as Headings, Images/Graphics, Paragraph text and Tables, as well as sub-sections thereof.
Tagging can be verified using the Accessibility Full Check or by viewing the Description tab of the Document Properties window (File>Properties…) under Advanced.
Note: Whenever possible, Tags should be defined or remediated in the original document using the provided authoring tools and then exported to PDF, to ensure the accessibility of future versions.
Before altering the Tags or Reading Order, it is recommended to save a copy of the document, as actions may not allow reversion.
To apply Tags:
Go to Tools>Accessibility and select Autotag Document. If the document already contains Tags, an alert pop-up will ask “Would you like to re-tag the document?”.
Use the Add Tags Report (Recognition Report) that appears in the Accessibility Navigation pane (See Figure 6) to review and resolve any potential issues.
Tags can be edited in the Tags pane by “right clicking” on a tagged element and choosing from the options. Tags can be further customized by right clicking an element and selecting Properties… Examples of Tag modifications include changes to the Title and Type of tag, and defining a language for specified text.
For details on Editing document structure and the Tags panel, see: 
· About the Tags panel
· Reading Order>Structure Types in this document.
· [bookmark: _Toc504657979][bookmark: _Toc504658037][bookmark: _Toc504659756]EXAMINE AND REPAIR THE TAG STRUCTURE (ADVANCED)
Figure 6
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How to achieve checklist item #5: Reading Order
The Reading Order can be checked using a Screen Reader or by using the Read Out Loud feature in Adobe Acrobat Pro. The Reading Order can also be viewed in the Order pane which lists content order from top to bottom in a tree view. Objects can be dragged up or down to modify the order, and tags can also be modified by “right clicking” or by using the Touch Up Reading Order tool (See Figure 7).
The Touch Up “Reading Order” tool (Tools>Accessibility>Reading Order) can be used to assign or modify a Tag. When the tool is selected, it appears as a pop-up window and the document displays content groups. Page content order can be selected to view the Reading Order of content groups within each page of the document. The content group items appear as grey boxes over the document content and will display a number on the top left indicating the order of each item. The first item [1] on each page should start on the top left unless otherwise specified. The Page content order should be arranged in a meaningful sequence that matches the visual presentation.
Figure 7
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Structure types can be chosen to show structure tags (e.g.; P for Paragraph or H1 for Heading level 1) which appear at the top right corner of the content groups, and can be used to verify and modify Tags.
Users are instructed to draw a rectangle (by dragging) around the content to select it, before assigning a new Structure Type by selecting the appropriate button (e.g.; Text, Heading 1, etc.) This process can be used to create an appropriately nested Heading structure for the entire document (also see checklist item #8 Headings).
Decorative and non-essential objects should be tagged as “Background” to automatically remove them from the Reading Order and streamline the reading experience. Re-ordering objects or tagging them as Background will not affect the visual appearance of the document but may affect Tags or Tag order.
Objects that are unwanted in the Reading Order can be tagged as background by right clicking on the item in the Reading Order pane, and selecting Tag as Background, or by using the Touch Up Reading Order tool.
Always manually verify that the document maintains a logical reading order which is supported by proper tagging.
[bookmark: _Toc504657980][bookmark: _Toc504658038][bookmark: _Toc504659757]Table Editor
Within the Touch Up Reading Order tool is a Table Editor button. Selecting Table Editor will highlight table cells and display table structure which can be modified to ensure accessibility. 
Note: The table must be selected before the Table editor can be enabled. 
Once enabled, the table will display a color outline. Right-clicking on a cell within the table and selecting Table Cell Properties allows for the assignment of Header/Data cells, within the Table Cell Properties window. An appropriate Column and/or Row “Scope” must also be applied to all heading assignments to support context during screen reader table navigation (See Figure 8).
Figure 8
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Tables should not be used for layout purposes alone whenever possible, and must have assigned Headers that repeat across pages.
Tables should not allow rows to break across pages.
For more information:
Using Adobe Acrobat Pro's Table Editor to repair mis-tagged tables
EXAMINE AND REPAIR THE TAG STRUCTURE (TABLES)
[bookmark: _Toc504657981][bookmark: _Toc504658039][bookmark: _Toc504659758]Reflow
The Reflow of a PDF document can be corrected using the Content panel (See Figure 9), rather than affect the Reading Order directly. Always use caution when making changes to the Document Order. Modifications can be made by dragging items up or down within the list.
View > Show/Hide > Navigation Panels > Content
See: Correct reflow problems with the Content panel
Figure 9
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How to achieve checklist item #6: Tab Order
A Tab order that is equivalent to the document order must be defined to support accessibility for keyboard only navigation.
All actionable items should receive visible keyboard focus including form controls. 
The Tab Order is often defined when the document structure types are designated, using standard document authoring tools. Correct document Structure Types, Reading Order and Tagging should be verified before fixing errors in the Tab Order.
To manually fix the Tab order:
A. Begin by selecting the Page Thumbnails panel from the navigation pane. 
B. Select a page from the list of thumbnails and from the Options menu select Page Properties.
C. Within Page Properties, select Tab Order and then Use Document Structure (See Figure 10).
D. Select OK.
E. Repeat the process for each page of the document. A select-all command can be used and Use Document Structure can be applied to all pages at once.
Figure 10
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[bookmark: _Toc504657982][bookmark: _Toc504658040][bookmark: _Toc504659759]How to achieve checklist item #7: Text and Whitespace
Note: It is best to make any text and spacing modifications within the original document to ensure changes are retained in future document versions. If changes cannot be made in the original document, select Tools>Edit PDF and use the appropriate tools found in the FORMAT section of Adobe Acrobat Pro (See Figure 11).
Figure 11
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[bookmark: _Toc504657983][bookmark: _Toc504658041][bookmark: _Toc504659760]Text
Always select a font size of 12-point or larger.
Avoid using serif fonts and italics whenever possible.
Ensure all characters map to Unicode, or replace them with images that have associated alt text.
Abbreviated text should include a definition/expansion as well, to clarify meaning for every first occurrence (e.g.; "Web Content Accessibility Guidelines (WCAG)").
This can be accomplished using a /E entry. 
For more information, see: PDF8: Providing definitions for abbreviations
[bookmark: _Toc504657984][bookmark: _Toc504658042][bookmark: _Toc504659761]Whitespace
Use the formatting options within authoring Applications to create whitespace (e.g. paragraph spacing, page breaks and columns). The Spacebar, Tabs or carriage returns should not be used to create a separation of visual content. 
[bookmark: _Toc504657985][bookmark: _Toc504658043][bookmark: _Toc504659762]How to achieve checklist item #8 Headings
All Headings, Titles and text formatted to visually appear as a heading, should receive Heading tags. This can be achieved using the formatting options found in the authoring tools of the original document. An appropriately nested Heading structure begins with a single H1 (Heading level 1) assignment and adds additional heading tags to match the visual layout, typically consisting of H2 – H6 Tags. Heading Tags must have a logical hierarchy and Heading levels must not be skipped. Refer to How to achieve checklist item #5: Reading Order to remediate any issues in Heading structure.
[bookmark: _Toc504657986][bookmark: _Toc504658044][bookmark: _Toc504659763]How to achieve checklist item #9: Forms
Adobe Acrobat Pro contains a Form Wizard that can create form fields. To begin, select Tools>Prepare Form. To utilize the Form Wizard, ensure the “Form Field auto detection” is ON before selecting Start (this is default behavior). This also places the document in a Form Editing Mode which gives users the ability to manually add and modify form controls (See Figure 12).
Figure 12
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Supported Form Fields include:
· Text Field
· Check Box
· Radio Button
· List Box.
· Combo Box
· Button
· Digital Signature Field
· Barcode
Each form control should have a meaningful visible label that is equally distinguishable by a screen reader. To edit a label, right click on a form control and choose Properties…From the Properties pop-up window, select the General tab. To add a visible name/label, type in the Name: field, then type an equivalent accessible name that will be read by a screen reader in the Tooltip: field.
Accessible forms provide users with:
A. Accessible labels/names for all controls/fields.
B. Instructions that are understandable by all users (e.g. not using color alone to convey meaning such as required fields).
C. A meaningful Tab/Reading Order
D. No Keyboard traps
E. No changes in focus that are not expected or conveyed to all users.
F. Identification and suggestions to correct errors.
G. Error prevention that allows for changes before submission when in regards to personal, legal or financial data.
To set the Tab order of a form, select an option within the Order Tabs drop down menu found in the Prepare Form pane (in the FIELDS section) or drag and drop the fields to the appropriate location in the FIELDS list.
To apply an error validation message to a form field, begin by selecting the form field, in the Prepare Form task pane, select the More drop down menu and choose Show Field Properties…Select the Validate tab and follow prompts to enter a range of values or to apply a custom script.
Include instructions when applicable and ensure logical placement.
All form controls should be manually checked for accessibility. To check keyboard only accessibility, use the Tab key to ensure all form fields receive focus during navigation, use the Spacebar to make a selection and arrow keys to navigate options or a list. Use the Read Out Loud function (under View) to hear the label/tooltip, or hover the mouse cursor on a field to see the accessible label/tooltip.
Including a “Submit” button, supports the accessibility of forms that may generate an HTTP request and may initiate a change of context. Add a “Submit” button using the Prepare Form tools. For more information, see: PDF 15: Providing submit buttons
It is recommended to complete any form editing before auto-tagging the document.
Note: Use HTML forms whenever possible.
For additional information, see:
Convert existing forms to fillable PDFs
[bookmark: _Toc504657987][bookmark: _Toc504658045][bookmark: _Toc504659764]How to achieve checklist item #10: Lists
Lists should be created using formatting within the original document authoring tools.
All sub-list items/multilevel lists must have properly nested and structured Tags.
List tags and structures can be modified using Adobe Acrobat Pro using the Tags pane.
“Right click” the object Tag and choose Properties…from the menu. The Content and Tag tab provide options for list structure Type and other modifications (See Figure 13).
For additional information, see:
Building a Proper List Structure
Using List tags for lists in PDF documents
Figure 13
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[bookmark: _Toc504657988][bookmark: _Toc504658046][bookmark: _Toc504659765]How to achieve checklist item #11: Images
[bookmark: _Toc504657989][bookmark: _Toc504658047][bookmark: _Toc504659766]Add Alternative Text to an Image
All images should retain image Tags and Alt Text applied in the original document authoring Application. 
Images should be Tagged as Figure/Image and should have descriptive Alt Text unless it is only for decoration in which case it should be Tagged as Background/Decorative figure/Artifact.
Refer to #4 Tags and #5 Reading Order to remediate any improperly tagged Images.
To add Alt Text to images and graphics; go to Tools>Set Alternate Text, and follow prompts in the pop-up window to add or modify Alt Text for all document images (See Figure 14). This method also allows users to check the Decorative figure checkbox, which applies an <Artifact> Tag to images that screen readers can bypass when navigating the document.
Figure 14
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Alt Text can also be modified in Tools>Reading Order by right clicking an image and choosing Edit Alternate Text. The pop-up window provides a text field to enter or edit Alternate Text.
Note:
a) Alt text should be concise, meaningful, and should convey the purpose of the image. Avoid verbose alt text that distracts the user from the point of the image. 
b) Complex chart data should not be included in alt text. All complex data should be provided in another format, such as within an accessible table or included within the text body and referenced in the Alt Text of the object/element. 
c) All multi-layer images, nested elements and/or images that consist of multiple elements should be consolidated and given appropriate Alt Text whenever possible. 
[bookmark: _Toc504657990][bookmark: _Toc504658048][bookmark: _Toc504659767]How to achieve checklist item #12: Color
Note: Remember that color-alone cannot be the only means of conveying information. Avoid using chart and graph styles that rely solely on color. Use labels or fills so that a secondary visual characteristic is present. 
Ensure that text to background color contrast is at least 4.5:1 for standard text and at least 3:1 for large text (14-point bold or greater). 
Several tools are available to test the contrast ratio (See Figure 15), including the Colour Contrast Analyzer.

Figure 15
[image: /Users/PerkinsAccess/Desktop/W2 Color.png]
[bookmark: _Toc504657991][bookmark: _Toc504658049][bookmark: _Toc504659768]How to achieve checklist item #13: Security
A secure document can prevent access by Assistive Technologies, although some Assistive Technology that has been registered with Adobe can bypass security features.
To remove security that may interfere with accessibility:
A. Go to File>Properties… and select the Security Tab.
B. In the Document Security section, choose No Security from the Security Method drop down menu (See Figure 16).
C. Select OK to close the Document Properties window.
Figure 16
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[bookmark: _Toc504657992][bookmark: _Toc504658050][bookmark: _Toc504659769]How to achieve checklist item #14: Image Only PDF
PDFs that contain images of paragraph text as a whole or in part, or that contain other inaccessible non-text content such as scanned documents or photos of documents, need to be converted to accessible digital text and Tagged properly to ensure meaningful Reading Order.
Optical Character Recognition (OCR) is applied to “Recognize Text” found in Image only PDF content.
A. Go to Tools>Enhance Scans. Note: The Enhance Scans tools appear in the secondary toolbar.
B. From the Enhance Scans tools, select Recognize Text and choose In This File from the drop-down menu.
C. Choose any applicable page options and select Recognize Text (See Figure 17).
Figure 17
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D. Corrections can be made to any text that may not have been correctly recognized, by choosing Correct Recognized Text from the Recognize Text drop down menu. You can Review recognized text by selecting the checkbox. Each uncertain instance is presented for verification or modification.
E. Make any necessary modifications by typing in the recognized as edit text field, and selecting Accept (See Figure 18).
Figure 18
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F. Select Tools>Accessibility and choose Autotag Document from the list of options. Verify and correct any inconsistencies in the Reading Order.
[bookmark: _Toc504657993][bookmark: _Toc504658051][bookmark: _Toc504659770]How to achieve checklist item #15: Page Numbering
Appropriate page numbering for all sections of the document, supports accessibility and facilitates navigation.
To edit or apply page numbers in Acrobat Pro:
A. Go to View>Show/Hide>Navigation Panes>Page Thumbnails.
B. Select the appropriate pages.
C. Choose Page Labels… from the Options dropdown menu in the Page Thumbnails pane (See Figure 19).
D. Choose the appropriate page range and numbering style options form the Page Numbering pop-up window (See Figure 19) before selecting OK.
Figure 19
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[bookmark: _Toc504657994][bookmark: _Toc504658052][bookmark: _Toc504659771]How to achieve checklist item #16: Timing
1. An accessible PDF cannot contain media that flickers or flashes more than three times in one second.  Document elements that violate this criterion must be removed.
2. No part of a PDF should contain a script that requires users to preform actions within a limited time. Scripts that require a timed response should be edited to ensure that all users have enough time, or removed.
[bookmark: _Toc504657995][bookmark: _Toc504658053][bookmark: _Toc504659772]How to achieve checklist item #17: Check
Figure 20
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Tools>Accessibility>Full Check (See Figure 20).
Choose applicable options and select Start Checking. By default, it runs a check of all categories in the entire document.
Examine results in the Accessibility Checker pane (See Figure 20). Expand items as needed.
Certain errors may be corrected by selecting “Fix” from the Options menu.
Correct all found errors.
For additional detail, once the Full Check is complete, select Tools>Accessibility>Accessibility Report.

[bookmark: _Toc504657996][bookmark: _Toc504658054][bookmark: _Toc504659773]Additional Resources
PDF Techniques for WCAG 2.0
Adobe Acrobat Accessibility
Create and verify PDF accessibility (Acrobat Pro)
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